re = /(?=.*FULL SET USER1)(?=.*Grp= 1)/m
str = 'Evnt= Closing report. System armed normally.
Dev= 0.
Grp= 1.
Usr= 2.
Xtra= FULL SET USER1.'
# Print the match result
str.match(re) do |match|
puts match.to_s
end