import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=.*FULL SET USER1)(?=.*Grp= 1)";
final String string = "Evnt= Closing report. System armed normally.\n"
+ "Dev= 0.\n"
+ "Grp= 1.\n"
+ "Usr= 2.\n"
+ "Xtra= FULL SET USER1.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}