$re = '/(?=.*FULL SET USER1)(?=.*Grp= 1)/ms';
$str = 'Evnt= Closing report. System armed normally.
Dev= 0.
Grp= 1.
Usr= 2.
Xtra= FULL SET USER1.';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);