use strict;
my $str = 'Evnt= Closing report. System armed normally.
Dev= 0.
Grp= 1.
Usr= 2.
Xtra= FULL SET USER1.';
my $regex = qr/(?=.*FULL SET USER1)(?=.*Grp= 1)/msp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}