#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)(?=.*FULL SET USER1)(?=.*Grp= 1)"
Local $sString = "Evnt= Closing report. System armed normally." & @CRLF & _
"Dev= 0." & @CRLF & _
"Grp= 1." & @CRLF & _
"Usr= 2." & @CRLF & _
"Xtra= FULL SET USER1."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")