import Foundation
let pattern = #"([a-zA-Z0-9_[\]]+)\s?((=|<|>|<=|>=)=?)\s?([-+]?([0-9]*\.[0-9]+|[0-9]+))\s?\(?(\w*)\)?\s?([-+±\s]*?([0-9]*\.[0-9]+|[0-9]+)\s?[a-zA-Z]*)?\s?(in|for)?\s?([0-9]*\.[0-9]+|[0-9]+)?(s|ms|min|us)?(\sfor|\sin)?\s?([0-9]*\.[0-9]+|[0-9]+)?(s|ms|min|us)?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Em01_Trq = 500 Nm +-50
Em01_Trq=-500Nm
Em01_Trq<+500rpm in 100ms for 10s
Em01_Trq<=-500rpm for 10s
Em01_Trq>=-500rpm in 10.5s
Em01_xxx>-500.505rpm
Em_md = 1(Torque)
Em_md = 1(Torque) in 50ms
Em_md = 1(Torque)
[Em_md] = 1(Torque) for 50.1min
Em01_Trq = 500 rpm +-50.6
EM01_PhaseCurr = 0 A ± 1 in 225ms
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)