// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([a-zA-Z0-9_[\]]+)\s?((=|<|>|<=|>=)=?)\s?([-+]?([0-9]*\.[0-9]+|[0-9]+))\s?\(?(\w*)\)?\s?([-+±\s]*?([0-9]*\.[0-9]+|[0-9]+)\s?[a-zA-Z]*)?\s?(in|for)?\s?([0-9]*\.[0-9]+|[0-9]+)?(s|ms|min|us)?(\sfor|\sin)?\s?([0-9]*\.[0-9]+|[0-9]+)?(s|ms|min|us)?").unwrap();
let string = "Em01_Trq = 500 Nm +-50
Em01_Trq=-500Nm
Em01_Trq<+500rpm in 100ms for 10s
Em01_Trq<=-500rpm for 10s
Em01_Trq>=-500rpm in 10.5s
Em01_xxx>-500.505rpm
Em_md = 1(Torque)
Em_md = 1(Torque) in 50ms
Em_md = 1(Torque)
[Em_md] = 1(Torque) for 50.1min
Em01_Trq = 500 rpm +-50.6
EM01_PhaseCurr = 0 A ± 1 in 225ms";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}