import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([a-zA-Z0-9_[\\]]+)\\s?((=|<|>|<=|>=)=?)\\s?([-+]?([0-9]*\\.[0-9]+|[0-9]+))\\s?\\(?(\\w*)\\)?\\s?([-+±\\s]*?([0-9]*\\.[0-9]+|[0-9]+)\\s?[a-zA-Z]*)?\\s?(in|for)?\\s?([0-9]*\\.[0-9]+|[0-9]+)?(s|ms|min|us)?(\\sfor|\\sin)?\\s?([0-9]*\\.[0-9]+|[0-9]+)?(s|ms|min|us)?";
final String string = "Em01_Trq = 500 Nm +-50\n"
+ "Em01_Trq=-500Nm\n"
+ "Em01_Trq<+500rpm in 100ms for 10s\n"
+ "Em01_Trq<=-500rpm for 10s\n"
+ "Em01_Trq>=-500rpm in 10.5s\n"
+ "Em01_xxx>-500.505rpm\n"
+ "Em_md = 1(Torque)\n"
+ "Em_md = 1(Torque) in 50ms\n"
+ "Em_md = 1(Torque) \n"
+ "[Em_md] = 1(Torque) for 50.1min\n"
+ "Em01_Trq = 500 rpm +-50.6\n"
+ "EM01_PhaseCurr = 0 A ± 1 in 225ms";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}