# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([a-zA-Z0-9_[\]]+)\s?((=|<|>|<=|>=)=?)\s?([-+]?([0-9]*\.[0-9]+|[0-9]+))\s?\(?(\w*)\)?\s?([-+±\s]*?([0-9]*\.[0-9]+|[0-9]+)\s?[a-zA-Z]*)?\s?(in|for)?\s?([0-9]*\.[0-9]+|[0-9]+)?(s|ms|min|us)?(\sfor|\sin)?\s?([0-9]*\.[0-9]+|[0-9]+)?(s|ms|min|us)?"
test_str = ("Em01_Trq = 500 Nm +-50\n"
"Em01_Trq=-500Nm\n"
"Em01_Trq<+500rpm in 100ms for 10s\n"
"Em01_Trq<=-500rpm for 10s\n"
"Em01_Trq>=-500rpm in 10.5s\n"
"Em01_xxx>-500.505rpm\n"
"Em_md = 1(Torque)\n"
"Em_md = 1(Torque) in 50ms\n"
"Em_md = 1(Torque) \n"
"[Em_md] = 1(Torque) for 50.1min\n"
"Em01_Trq = 500 rpm +-50.6\n"
"EM01_PhaseCurr = 0 A ± 1 in 225ms")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.