re = /<\/?\w+((\s+\w+(\s*=\s*(?:".*?"|'.*?'|[^'">\s]+))?)+\s*|\s*)\/?>/
str = 'a paragraph with a nested image: <img src="/sites/default/files/simpletest/254354/image-test.png"/> a paragraph with a nested image: <img src="/sites/default/files/simpletest/254354/image-test.png"/>a paragraph with a nested image: <img src="/sites/default/files/simpletest/254354/image-test.png">asdf</img> asdf
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end