$re = '/<\/?\w+((\s+\w+(\s*=\s*(?:".*?"|\'.*?\'|[^\'">\s]+))?)+\s*|\s*)\/?>/';
$str = 'a paragraph with a nested image: <img src="/sites/default/files/simpletest/254354/image-test.png"/> a paragraph with a nested image: <img src="/sites/default/files/simpletest/254354/image-test.png"/>a paragraph with a nested image: <img src="/sites/default/files/simpletest/254354/image-test.png">asdf</img> asdf
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);