import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<\\/?\\w+((\\s+\\w+(\\s*=\\s*(?:\".*?\"|'.*?'|[^'\">\\s]+))?)+\\s*|\\s*)\\/?>";
final String string = "a paragraph with a nested image: <img src=\"/sites/default/files/simpletest/254354/image-test.png\"/> a paragraph with a nested image: <img src=\"/sites/default/files/simpletest/254354/image-test.png\"/>a paragraph with a nested image: <img src=\"/sites/default/files/simpletest/254354/image-test.png\">asdf</img> asdf\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}