#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<\/?\w+((\s+\w+(\s*=\s*(?:".*?"|'.*?'|[^'">\s]+))?)+\s*|\s*)\/?>"
Local $sString = "a paragraph with a nested image: <img src="/sites/default/files/simpletest/254354/image-test.png"/> a paragraph with a nested image: <img src="/sites/default/files/simpletest/254354/image-test.png"/>a paragraph with a nested image: <img src="/sites/default/files/simpletest/254354/image-test.png">asdf</img> asdf" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")