const regex = /<\/?\w+((\s+\w+(\s*=\s*(?:".*?"|'.*?'|[^'">\s]+))?)+\s*|\s*)\/?>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<\\\/?\\w+((\\s+\\w+(\\s*=\\s*(?:".*?"|\'.*?\'|[^\'">\\s]+))?)+\\s*|\\s*)\\\/?>', 'g')
const str = `a paragraph with a nested image: <img src="/sites/default/files/simpletest/254354/image-test.png"/> a paragraph with a nested image: <img src="/sites/default/files/simpletest/254354/image-test.png"/>a paragraph with a nested image: <img src="/sites/default/files/simpletest/254354/image-test.png">asdf</img> asdf
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}