re = /(CDSTransacaoItem)?(\.FieldByName\(\')?(PercentualDesconto){1}(\'\))?/i
str = 'CDSTransacaoItemPercentualDesconto
CDSTransacaoItem.FieldByName(\'PercentualDesconto\')
PercentualDesconto
.FieldByName(\'PercentualDesconto\')'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end