#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(CDSTransacaoItem)?(\.FieldByName\(\')?(PercentualDesconto){1}(\'\))?"
Local $sString = "CDSTransacaoItemPercentualDesconto" & @CRLF & _
"CDSTransacaoItem.FieldByName('PercentualDesconto')" & @CRLF & _
"PercentualDesconto" & @CRLF & _
".FieldByName('PercentualDesconto')"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")