package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(CDSTransacaoItem)?(\.FieldByName\(\')?(PercentualDesconto){1}(\'\))?`)
var str = `CDSTransacaoItemPercentualDesconto
CDSTransacaoItem.FieldByName('PercentualDesconto')
PercentualDesconto
.FieldByName('PercentualDesconto')`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}