$re = '/(CDSTransacaoItem)?(\.FieldByName\(\')?(PercentualDesconto){1}(\'\))?/i';
$str = 'CDSTransacaoItemPercentualDesconto
CDSTransacaoItem.FieldByName(\'PercentualDesconto\')
PercentualDesconto
.FieldByName(\'PercentualDesconto\')';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);