import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(CDSTransacaoItem)?(\\.FieldByName\\(\\')?(PercentualDesconto){1}(\\'\\))?";
final String string = "CDSTransacaoItemPercentualDesconto\n"
+ "CDSTransacaoItem.FieldByName('PercentualDesconto')\n"
+ "PercentualDesconto\n"
+ ".FieldByName('PercentualDesconto')";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}