import Foundation
let pattern = #"^[1-9]{1}[0-9]{3} ?(?!sa|sd|ss)[a-zA-Z]{2}$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"1234 AB"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}