using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[1-9]{1}[0-9]{3} ?(?!sa|sd|ss)[a-zA-Z]{2}$";
string substitution = @"";
string input = @"1234 AB";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}