# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^[1-9]{1}[0-9]{3} ?(?!sa|sd|ss)[a-zA-Z]{2}$//;t' <<< "1234 AB"