const regex = /^[1-9]{1}[0-9]{3} ?(?!sa|sd|ss)[a-zA-Z]{2}$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[1-9]{1}[0-9]{3} ?(?!sa|sd|ss)[a-zA-Z]{2}$', '')
const str = `1234 AB`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);