$re = '/^[1-9]{1}[0-9]{3} ?(?!sa|sd|ss)[a-zA-Z]{2}$/';
$str = '1234 AB';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;