re = /<VirtualHost[*:0-9\s]+>([\S\s]+?)<\/VirtualHost>/
str = '...
# First VHost...
<VirtualHost *:80 *:8082>
# Any number of configs
# and set up options for
# Apache
</VirtualHost>
# Second VHost...
<VirtualHost *:80 *:8082>
# Any number of configs
# and set up options for
# Apache
</VirtualHost>
# Third VHost...
<VirtualHost *:80 *:8082>
# Any number of configs
# and set up options for
# Apache
</VirtualHost>
....'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end