using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<VirtualHost[*:0-9\s]+>([\S\s]+?)<\/VirtualHost>";
string input = @"...
# First VHost...
<VirtualHost *:80 *:8082>
# Any number of configs
# and set up options for
# Apache
</VirtualHost>
# Second VHost...
<VirtualHost *:80 *:8082>
# Any number of configs
# and set up options for
# Apache
</VirtualHost>
# Third VHost...
<VirtualHost *:80 *:8082>
# Any number of configs
# and set up options for
# Apache
</VirtualHost>
....";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}