import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<VirtualHost[*:0-9\\s]+>([\\S\\s]+?)<\\/VirtualHost>";
final String string = "...\n"
+ "# First VHost...\n"
+ "<VirtualHost *:80 *:8082>\n"
+ " # Any number of configs\n"
+ " # and set up options for\n"
+ " # Apache\n"
+ "</VirtualHost>\n\n"
+ "# Second VHost...\n"
+ "<VirtualHost *:80 *:8082>\n"
+ " # Any number of configs\n"
+ " # and set up options for\n"
+ " # Apache\n"
+ "</VirtualHost>\n\n"
+ "# Third VHost...\n"
+ "<VirtualHost *:80 *:8082>\n"
+ " # Any number of configs\n"
+ " # and set up options for\n"
+ " # Apache\n"
+ "</VirtualHost>\n"
+ "....";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}