package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<VirtualHost[*:0-9\s]+>([\S\s]+?)<\/VirtualHost>`)
var str = `...
# First VHost...
<VirtualHost *:80 *:8082>
# Any number of configs
# and set up options for
# Apache
</VirtualHost>
# Second VHost...
<VirtualHost *:80 *:8082>
# Any number of configs
# and set up options for
# Apache
</VirtualHost>
# Third VHost...
<VirtualHost *:80 *:8082>
# Any number of configs
# and set up options for
# Apache
</VirtualHost>
....`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}