// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"RM\*ACEHV1-(?:[A-Z]{3})?(\d*(?:\.\d*)?)(?:.*)?(-.*)?").unwrap();
let string = "RM*ACEHV1-10.00-LA
RM*ACEHV1-EUR10.00-asdf-LA
RM*ACEHV1-EUR4321.12LALA-LA
RM*ACEHV1-12-LA
RM*ACEHV1-10.00";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}