import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "RM\\*ACEHV1-(?:[A-Z]{3})?(\\d*(?:\\.\\d*)?)(?:.*)?(-.*)?";
final String string = "RM*ACEHV1-10.00-LA\n"
+ "RM*ACEHV1-EUR10.00-asdf-LA\n"
+ "RM*ACEHV1-EUR4321.12LALA-LA\n"
+ "RM*ACEHV1-12-LA\n"
+ "RM*ACEHV1-10.00";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}