using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"RM\*ACEHV1-(?:[A-Z]{3})?(\d*(?:\.\d*)?)(?:.*)?(-.*)?";
string input = @"RM*ACEHV1-10.00-LA
RM*ACEHV1-EUR10.00-asdf-LA
RM*ACEHV1-EUR4321.12LALA-LA
RM*ACEHV1-12-LA
RM*ACEHV1-10.00";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}