#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "RM\*ACEHV1-(?:[A-Z]{3})?(\d*(?:\.\d*)?)(?:.*)?(-.*)?"
Local $sString = "RM*ACEHV1-10.00-LA" & @CRLF & _
"RM*ACEHV1-EUR10.00-asdf-LA" & @CRLF & _
"RM*ACEHV1-EUR4321.12LALA-LA" & @CRLF & _
"RM*ACEHV1-12-LA" & @CRLF & _
"RM*ACEHV1-10.00"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")