re = /RM\*ACEHV1-(?:[A-Z]{3})?(\d*(?:\.\d*)?)(?:.*)?(-.*)?/
str = 'RM*ACEHV1-10.00-LA
RM*ACEHV1-EUR10.00-asdf-LA
RM*ACEHV1-EUR4321.12LALA-LA
RM*ACEHV1-12-LA
RM*ACEHV1-10.00'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end