const regex = /Military\n\s+([0-9,]+)\n\s+\+([0-9.]+)% Magic Effectiveness Rune Production\n\s+([0-9,]+)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Military\\n\\s+([0-9,]+)\\n\\s+\\+([0-9.]+)% Magic Effectiveness Rune Production\\n\\s+([0-9,]+)', '')
const str = ` Military
914,519
+97.5% Magic Effectiveness Rune Production
0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}