#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "Military\n\s+([0-9,]+)\n\s+\+([0-9.]+)% Magic Effectiveness Rune Production\n\s+([0-9,]+)"
Local $sString = " Military" & @CRLF & _
" 914,519" & @CRLF & _
" +97.5% Magic Effectiveness Rune Production" & @CRLF & _
" 0"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")