package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Military\n\s+([0-9,]+)\n\s+\+([0-9.]+)% Magic Effectiveness Rune Production\n\s+([0-9,]+)`)
var str = ` Military
914,519
+97.5% Magic Effectiveness Rune Production
0`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}