using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Military\n\s+([0-9,]+)\n\s+\+([0-9.]+)% Magic Effectiveness Rune Production\n\s+([0-9,]+)";
string input = @" Military
914,519
+97.5% Magic Effectiveness Rune Production
0";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}