import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Military\\n\\s+([0-9,]+)\\n\\s+\\+([0-9.]+)% Magic Effectiveness Rune Production\\n\\s+([0-9,]+)";
final String string = " Military\n"
+ " 914,519\n"
+ " +97.5% Magic Effectiveness Rune Production\n"
+ " 0";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}