import Foundation
let pattern = #"Tool Call[ ]{0,2}\K[0-9]+|Tool Call[ ]{0,2}\K[\"][0-9]+[\"]|Tool Call[ ]{0,2}\K[\"]?...[\"]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Tool Call "04561"
Tool Call 1613 S1261
Tool Call 4301480
Tool Call "ABE" F94916
Tool Call S161300
Tool Call F26161
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)