import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Tool Call[ ]{0,2}\\K[0-9]+|Tool Call[ ]{0,2}\\K[\\\"][0-9]+[\\\"]|Tool Call[ ]{0,2}\\K[\\\"]?...[\\\"]";
final String string = "Tool Call \"04561\"\n"
+ "Tool Call 1613 S1261\n"
+ "Tool Call 4301480\n"
+ "Tool Call \"ABE\" F94916\n"
+ "Tool Call S161300\n"
+ "Tool Call F26161";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}