$re = '/Tool Call[ ]{0,2}\K[0-9]+|Tool Call[ ]{0,2}\K[\"][0-9]+[\"]|Tool Call[ ]{0,2}\K[\"]?...[\"]/';
$str = 'Tool Call "04561"
Tool Call 1613 S1261
Tool Call 4301480
Tool Call "ABE" F94916
Tool Call S161300
Tool Call F26161';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);