use strict;
my $str = 'Tool Call "04561"
Tool Call 1613 S1261
Tool Call 4301480
Tool Call "ABE" F94916
Tool Call S161300
Tool Call F26161';
my $regex = qr/Tool Call[ ]{0,2}\K[0-9]+|Tool Call[ ]{0,2}\K[\"][0-9]+[\"]|Tool Call[ ]{0,2}\K[\"]?...[\"]/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}