const regex = new RegExp('Tool Call[ ]{0,2}\\K[0-9]+|Tool Call[ ]{0,2}\\K[\\"][0-9]+[\\"]|Tool Call[ ]{0,2}\\K[\\"]?...[\\"]', 'g')
const str = `Tool Call "04561"
Tool Call 1613 S1261
Tool Call 4301480
Tool Call "ABE" F94916
Tool Call S161300
Tool Call F26161`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}