// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?x)# the opening delimiter
(["'])
# the body is
(?:
# either an escaped delimiter
\\\1
# or
|
# anything except a backslash or a delimiter
(?!\\|\1).
# (can't put \1 in a character class, so use a negative lookahead)
)*
# repeated zero or more times# the closing delimiter
\1"#).unwrap();
let string = "{if Server:GetPhpSelf == \"/ind'ex.php\"}
foo 'hhhh\"hhh\"\"hhh' plonk
foo \"meep\\\"meep\" plonk
foo 'meep\\'meep' plonk";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}