using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"# the opening delimiter
([""'])
# the body is
(?:
# either an escaped delimiter
\\\1
# or
|
# anything except a backslash or a delimiter
(?!\\|\1).
# (can't put \1 in a character class, so use a negative lookahead)
)*
# repeated zero or more times# the closing delimiter
\1";
string input = @"{if Server:GetPhpSelf == ""/ind'ex.php""}
foo 'hhhh""hhh""hhh' plonk
foo ""meep\""meep"" plonk
foo 'meep\'meep' plonk";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}