$re = '/# the opening delimiter
(["\'])
# the body is
(?:
# either an escaped delimiter
\\\\\1
# or
|
# anything except a backslash or a delimiter
(?!\\\\|\1).
# (can\'t put \1 in a character class, so use a negative lookahead)
)*
# repeated zero or more times# the closing delimiter
\1/x';
$str = '{if Server:GetPhpSelf == "/ind\'ex.php"}
foo \'hhhh"hhh""hhh\' plonk
foo "meep\\"meep" plonk
foo \'meep\\\'meep\' plonk';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);