use strict;
my $str = '{if Server:GetPhpSelf == "/ind\'ex.php"}
foo \'hhhh"hhh""hhh\' plonk
foo "meep\\"meep" plonk
foo \'meep\\\'meep\' plonk';
my $regex = qr/# the opening delimiter
(["'])
# the body is
(?:
# either an escaped delimiter
\\\1
# or
|
# anything except a backslash or a delimiter
(?!\\|\1).
# (can't put \1 in a character class, so use a negative lookahead)
)*
# repeated zero or more times# the closing delimiter
\1/xp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}