import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "# the opening delimiter
\n"
+ "([\"'])
\n"
+ "# the body is
\n"
+ "(?:
\n"
+ " # either an escaped delimiter
\n"
+ " \\\\\\1
\n"
+ " # or
\n"
+ " |
\n"
+ " # anything except a backslash or a delimiter
\n"
+ " (?!\\\\|\\1).
\n"
+ " # (can't put \\1 in a character class, so use a negative lookahead)
\n"
+ ")*
\n"
+ "# repeated zero or more times# the closing delimiter
\n"
+ "\\1";
final String string = "{if Server:GetPhpSelf == \"/ind'ex.php\"}\n"
+ "foo 'hhhh\"hhh\"\"hhh' plonk\n"
+ "foo \"meep\\\"meep\" plonk\n"
+ "foo 'meep\\'meep' plonk";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}