// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:\d+(\d{1,3})*([\,\ ]\d{3})*\.\d+)?.+(sqft)").unwrap();
let string = "\"4,882 \\t\\t\\t\\t\\t\\tsqft \\t\\t\\t\\t\\t\\t\\t\\t\\t\\t\\t\\t\\t\\t\\t/ \\t\\t\\t\\t\\t\\t\\t\\t\\t\\t454 \\t\\t\\t\\t\\t\\tsqm\"
\"4,882 \\t\\t\\t\\t\\t\\tsqft \\t\\t\\t\\t\\t\\t\\t\\t\\t\\t\\t\\t\\t\\t\\t/ \\t\\t\\t\\t\\t\\t\\t\\t\\t\\t454 \\t\\t\\t\\t\\t\\tsqm\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}