const regex = /(?:\d+(\d{1,3})*([\,\ ]\d{3})*\.\d+)?.+(sqft)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\d+(\\d{1,3})*([\\,\\ ]\\d{3})*\\.\\d+)?.+(sqft)', 'gm')
const str = `"4,882 \\t\\t\\t\\t\\t\\tsqft \\t\\t\\t\\t\\t\\t\\t\\t\\t\\t\\t\\t\\t\\t\\t/ \\t\\t\\t\\t\\t\\t\\t\\t\\t\\t454 \\t\\t\\t\\t\\t\\tsqm"
"4,882 \\t\\t\\t\\t\\t\\tsqft \\t\\t\\t\\t\\t\\t\\t\\t\\t\\t\\t\\t\\t\\t\\t/ \\t\\t\\t\\t\\t\\t\\t\\t\\t\\t454 \\t\\t\\t\\t\\t\\tsqm"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}